Pages

Wednesday, November 15, 2017

Firefox Update Breaks Smart View Links (On-Premise + Cloud)

Mozilla has just released a new version of their browser: Firefox 57 “Quantum”. The new release is promised to be even faster than before, but there is one downside as well; it disables extensions that haven’t been implemented with the new WebExtensions technology. The extension installed by Oracle Smart View is among the "legacy" extensions that can't be used with the latest Firefox version.


This means that the "Open in Smart View" links in HFM, Planning, PBCS and FCCS will cease to work in latest Firefox because they rely on the old extension.

Open in Smart View (HFM)

Open in Smart View (PBCS)

Oracle has published the following statement in the latest Smart View readme file and also in the monthly notes for the EPM Cloud Services.

USING FIREFOX ESR 52.4.2 WITH SMART VIEW
Future releases of Mozilla Firefox will be phasing out support for XUL-based add-ons such as Smart View. Starting in mid-November 2017, only add-ons and extensions built with new web extension technology will work in Firefox. Therefore, Smart View 11.1.2.5.710 only supports Firefox versions up to ESR 52.4.1. If you want to continue using Firefox with Smart View 11.1.2.5.710, do not upgrade your Firefox browser. If your Firefox browser is set to automatically install updates, Oracle recommends changing the setting to “Check for updates, but let me choose whether to install them.” See the Firefox help for instructions on changing this setting.

I have not heard any official statements yet, but I hope that Oracle will update the Smart View extension to work with the latest version soon. Meanwhile your best option is to use the less frequently updated Firefox ESR version as Oracle recommends.

No comments :

Post a Comment